pandas使ってるときにpickleファイルを読み込むとエラーが出た

AttributeError: Can't get attribute 'new_block' on <module'pandas.core.internals.blocks' from '/opt/conda/lib/python3.7/site-packages/pandas/core/internals/blocks.py'>

なんかよくわからんけど、coreのところでエラーが出てるっぽい

原因を調査してみると
pickleファイルを作った環境と、エラーが出ている環境で

pip show pandas

をしてみると
1.2.4, 1.3.4とバージョンが一つ違った

エラーが出ている方では1.2.4だったので

pip install pandas==1.3.4

としてやってpandasのバージョンを合わせてあげると読み込みがうまくいった。
こんなところでちょっとハマったのでメモ